Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
licialime00
21.04.2022 15:49 •
Информатика
Задать массив m(12) случайными числами от 9 до 54. увеличить на 5 элементы массива, кратные 3. увеличить на 5 элементы массива, кратные 3, стоящие на четных местах.
Ответ:
katyagulina666
04.10.2020 09:06
Var
a:array[1..12] of integer;
i:integer;
begin
for i:=1 to 12 do
begin
a[i]:=random(45)+9;
write(a[i]," ");
end;
writeln();
for i:=1 to 12 do
begin
if ((a[i] mod 3)=0) and ((i mod 2)=0) then
a[i]:=a[i]+5;
if ((a[i] mod 3)=0) then
a[i]:=a[i]+5;
write(a[i]," ");
end;
end
0,0
(0 оценок)
Популярные вопросы: Информатика
nikonova1977
19.06.2022 01:38
Pascal. логический тип данных проверить истинность высказывания: данные числа x, y являются координатами точки, лежащей во второй координатной четверти . требуется вывести...
Надя0301
01.02.2020 10:20
Сделать информатику паскаль! составить программу, которая выводит сообщение о том,периметр какого из двух треугольников меньше и чему он равен. известны стороны данных...
gordeeva2003
06.03.2022 10:38
Впереводе с на это устройство называется начинается на н 5 букв...
svetlanasalamon
18.09.2021 07:30
Что такое форматирование данных...
yestarday23
22.10.2020 21:55
Деректер типі дегеніміз не? көмектесіндерші ...
DanilSv040
26.03.2021 02:03
1. Сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен случайному трехзначному...
Alisa45612
28.08.2021 07:45
Напишите программу, которая при наборе с клавиатуры названия страны выводит на экран название столицыданной страны и численность населения, проживающегов ней.Население...
Данииб
08.01.2020 09:24
Постепенное прекращение созыва сословно -представительных органов власти, а именно означало усиление власти и укрепление самодержавия...
vvkim87
18.06.2022 04:58
Решите уравнение подробнооо 15 б ...
rokovayajenshi
14.12.2021 00:08
Чем занимался Робинзон Крузо во время первого путешествия в Гвинению...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a:array[1..12] of integer;
i:integer;
begin
for i:=1 to 12 do
begin
a[i]:=random(45)+9;
write(a[i]," ");
end;
writeln();
for i:=1 to 12 do
begin
if ((a[i] mod 3)=0) and ((i mod 2)=0) then
a[i]:=a[i]+5;
if ((a[i] mod 3)=0) then
a[i]:=a[i]+5;
write(a[i]," ");
end;
end