Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
daniilkeidi
27.02.2022 06:14 •
Информатика
Переделать в паскале в формат while var n,i,k: integer; begin k: =2; write('введите число n'); readln(n); for i: = 2 to n div 2 do if n mod i = 0 then k: =k+1; writeln(,k); end.
Ответ:
0Человек0
02.08.2020 11:57
Просто перевод заданного кода
var
n, i, k: integer;
begin
k := 2;
write('введите число n');
readln(n);
i := 2;
while i <= n div 2 do
begin
if n mod i = 0 then
k := k + 1;
i := i + 1;
end;
writeln(k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Вишенка200523
17.08.2021 03:25
Какова вероятность того, что из колоды в 36 игральных карт будут подряд вынуты 2 туза?...
NEASA
20.08.2021 01:40
Программа на паскале 3/(1*2)*6/(2*4)*9/(3*6)*12/(4*8)*...
миша29112000
20.08.2021 01:40
Даны числа m и n.составить программу следующего содержания: если числа положительные и их сумма больше 100,вывести отношение числа m к числу n .если числа положительные и их сумма...
sauleshka3
21.04.2021 12:52
На старых школьных компьютерах ( Корвет , Электроника-УКНЦ и др.) файловая система была организована так. На компьютере могло быть два дисковода:А: и В:. Имена всех файлов в каталоге...
alua070707
05.08.2022 20:39
У текстовий документ можнавставити ...? *...
шиканова
14.02.2022 19:24
Питон Напишите игру,любую тематику....
Vica73751
03.12.2022 12:47
В графическом интерфейсе используется только клавиатура для ввода задач для oc...
OwL505
12.07.2022 12:46
Действительно ли волга собирает 7000 рек с площади своего бассейна? если нет, то сколько? какие крупные горные реки есть в бассейне волги? есть ли пороги на волге? если есть, то...
artem28
12.07.2022 12:46
Як буде слово батько в давальном падеже по украинскому языку!...
Kirkorow
12.07.2022 12:46
Вычислите а)√11²+60² б) √85²-84² в)√2,5²-2,4²...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
n, i, k: integer;
begin
k := 2;
write('введите число n');
readln(n);
i := 2;
while i <= n div 2 do
begin
if n mod i = 0 then
k := k + 1;
i := i + 1;
end;
writeln(k);
end.