В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
BlackStyle69
BlackStyle69
24.01.2022 04:19 •  Информатика

Написать программу pascal, которая выводила бы число в обратной последовательности

Ответ:
12345671251
12345671251
04.10.2020 07:18
Procedure Chisla(n : Integer);
var    a : Integer;
begin 
   if (n < 1) then 
WriteLn   
  else 
  begin 
       Read(a);       
if (Abs(a) < 1000) then       
begin           
Chisla(n-1);           
Write(a,' ');       
 end       
else           
 Chisla(n);   
 end;end; function ReadN() : Integer;
var   
n : Integer;begin   
Write('n=');   
ReadLn(n);   
if Not(n in [0..1000]) then       
n := ReadN();   
ReadN := n;end; var   
n : Integer; begin   
n := ReadN();   
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter'); 
   Chisla(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?