В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
19283746521
19283746521
25.05.2021 12:19 •  Информатика

Составить программу которая посчитает количество квадратных чисел от 1 до 100?

Ответ:
g8trouble
g8trouble
08.09.2020 11:21
Сумма натуральных чисел из промежутка от 1 до 100, которые делятся на 17 и сумма цифр, которых не превышает 7. Можно перебором} var i,s:integer; begin s:=0; for i:=1 to 100 do if (i mod 17=0) and (i div 10 + i mod 10<7) then s:=s+i; writeln(s); end. {результат 51} { Можно оптимизировать в цикле изменив for i:=1 to 100 do на for i:=17 to 100 do} {2 вариантө оптимальнее - перебираем только числа кратные 17] var i,s:integer; begin s:=0; i:=17; while i<=100 do begin if (i div 10 + i mod 10<7) then s:=s+i; i:=i+17; end; writeln(s); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?