В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yanamalikova
yanamalikova
04.03.2021 08:55 •  Информатика

Паскаль абс: составить программу нахождения чисел из интервала [n; m], имеющих наибольшее количество делителей( количество делителей определить с подпрограммы)

Ответ:
assija56
assija56
04.10.2020 02:54
//PascalABC.NET 3.2 сборка 1318

var
  n, m, max, k, i: integer;
  ar: array of integer;

function CountOfDel(n: integer): integer;
var
  i, k: integer;
begin
if n>0 then
begin
  for i := 1 to n do
    if n mod i = 0 then inc(k);
end
  else
  for i:= n to -1 do
    if n mod i = 0 then
 inc(k);
  CountofDel := k;
if n=0 then
  CountofDel:=0;
end;

begin
  readln(n, m);
  k := 0;
  max := 0;
  for i := n to m do
  begin
    if CountOfDel(i)=0 then
      begin
        writeln('0');
        exit;
      end;
    if CountOfDel(i) > max then
    begin
      k := 1;
      setlength(ar, k);
      ar[k - 1] := i;
      max := CountOfDel(i);
    end
    else
    if CountOfDel(i) = max then
    begin
      inc(k);
      setlength(ar, k);
      ar[k - 1] := i;
    end;
  end;
  for i := 0 to k - 1 do
    write(ar[i]:4);
end.

Пример ввода:
1 10
Пример вывода:
6 8 10
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?