Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
DianaTesl
18.01.2023 21:49 •
Информатика
Склавиатуры вводится натуральное число n. программа выводит максимальную нечетную цифру числа. написать программу на паскале.
Ответ:
сева167
04.10.2020 00:07
Var
max, n, t: integer;
begin
readln(n);
max := -1;
while n > 0 do
begin
t := n mod 10;
if (t mod 2 = 1) and (max < t) then
max := t;
n := n div 10;
end;
if max = -1 then writeln('Нет такого числа')
else
writeln('Max = ', max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Дария2403
02.06.2021 06:28
Сколько времени будет проходить передача файла размером 512 кбайт по сети, скорость которой составляет 128 кбит/с?...
Uchenik66677
02.06.2021 06:28
Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет ( все координаты отличны от 0 ) решение в c++...
tsukikokawaii
15.12.2020 18:49
Создайте новый файл 10.html со следующей таблицей: ширина таблицы - 500 ширина 1 ячейки - 150 ширина 2 ячейки - 350 нужен код написанный в блокноте на это ....
syltanchik1338
09.05.2022 21:22
1) дано линейное уравнение: ах+b=0 решить его в соответствии с параметрами а и b. 2) найти вещественное в корне квадратное уравнение ax^2+bx+c=0. программирование это. : )...
Reshebnikov
09.05.2022 21:22
Составьте программу нахождения суммы всех целых чисел в диапазоне от -5 до n...
Ученик2281337228
01.08.2020 21:13
Составе программу вычисления произведения натуральных чисел от 7 до 27...
shefer84
01.08.2020 21:13
Выходные данные даны три натуральных числа a, b, c, записанные в отдельных строках. определите, существует ли треугольник с такими сторонами ( использовать неравенство треугольника...
aydin123
24.01.2023 16:12
Можно ли в питоне сделать так,чтобы при вводе любого числа выводилось yes,т.е: a = int(input())if a == (2 ** x):print( YES )else:print( NO )и вот здесь,вместо x, надо такое условие,что...
nastyakotika
04.06.2023 19:26
Растровый графический файл содержит цветное изображение с палитрой из 256 цветов размером 10×10 точек. каков информационный объем этого файла?...
ГульнараС
04.06.2023 19:26
Какой информационный объем будет иметь двухцветное графическое растровое изображение размером 800×600...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
max, n, t: integer;
begin
readln(n);
max := -1;
while n > 0 do
begin
t := n mod 10;
if (t mod 2 = 1) and (max < t) then
max := t;
n := n div 10;
end;
if max = -1 then writeln('Нет такого числа')
else
writeln('Max = ', max);
end.