Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
местоимение111
08.06.2023 12:36 •
Информатика
Составить программу паскаль которая будет вычислять периметр и площадь прямоугольника. и программу которая будет вычислять косинус углов треугольника а,в,с
Ответ:
алекей4
03.10.2020 21:36
Периметр прямоугольника: P=2(a+b). Площадь: S=ab
Косинусы углов в треугольнике:
cosA=(b²+c²-a²)/(2bc); cosB=(a²+c²-b²)/(2ac); cosC=(a²+b²-c²)/(2ab)
var
a,b:real;
begin
Write('Введите a,b: ');
Read(a,b);
Write('P=',2*(a+b),', S=',a*b)
end.
Тестовое решение
Введите a,b: 12.2 8
P=40.4, S=97.6
var
a,b,c,cosA,cosB,cosC:real;
begin
Write('Введите a,b,c: ');
Read(a,b,c);
cosA:=(b*b+c*c-a*a)/(2*b*c);
cosB:=(a*a+c*c-b*b)/(2*a*c);
cosC:=(a*a+b*b-c*c)/(2*a*b);
Write('cosA=',cosA,', cosB=',cosB,', cosC=',cosC)
end.
Тестовое решение
Введите a,b,c: 15.3 8 14.2
cosA=0.138864436619718, cosB=0.855495719414526, cosC=0.393995098039216
0,0
(0 оценок)
Популярные вопросы: Информатика
sashka1281
10.04.2022 21:26
Директор нанял двух работников и пообещал им по окончании работы дать каждому по 5 литров вина. когда работа была сделана, директор велел отдать работникам 3 кувшина. один кувшин...
бэйба123
10.04.2022 21:26
Напишите результат выполнения следующей программы: program z; var i: integer; begin for i: =5 downto 1 do write ( * ); end....
timofeevele
01.10.2021 07:04
Даны два целочисленных массива состоящие из 6 элементов.Первый массив задан с клавиатуры,второй - с датчика случайных чисел.Сформировать третий массив из значений первого и второго...
xk1
20.11.2022 22:35
Заполни пустые клетки синонимами шум- жара- беда- мороз- пурга- грусть- прочный- просить- смеяться- небольшой- - додумать-...
Лолалис
20.11.2022 22:35
Склавиатуры вводится число n, за ним массив из n целых чисел и число x. найдите количество элементов массива, значение которых равно x*x....
Belatrissa11
20.11.2022 22:35
Написать программу для паскаля. 1. написать программу нахождения произведения n чисел. 2. написать программу, рисующую на экране 5 цветных квадратов и 5 цветных кругов. размеры квадратов...
anonim000002
10.02.2022 21:06
Переведите я всегда мечтала стать продавцом в зоомагазине на казахском проспекте. там такие милые морские свинки, веселые и дружелюбные хомячки,игривые котята,красивые попугайчики....
Katteerina25
10.02.2022 21:06
Паскаль вывести значение каждого третьего элемента последовательности, начиная с первого....
egor2002browhnq9
10.02.2022 21:06
Выпишите грамматическую основу предложения (20) (20)ставили женьке пятерки за поведение....
romsik1999
10.02.2022 21:06
Ккаким частям речи относятся слова ради, через, между, из-за, из?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Косинусы углов в треугольнике:
cosA=(b²+c²-a²)/(2bc); cosB=(a²+c²-b²)/(2ac); cosC=(a²+b²-c²)/(2ab)
var
a,b:real;
begin
Write('Введите a,b: ');
Read(a,b);
Write('P=',2*(a+b),', S=',a*b)
end.
Тестовое решение
Введите a,b: 12.2 8
P=40.4, S=97.6
var
a,b,c,cosA,cosB,cosC:real;
begin
Write('Введите a,b,c: ');
Read(a,b,c);
cosA:=(b*b+c*c-a*a)/(2*b*c);
cosB:=(a*a+c*c-b*b)/(2*a*c);
cosC:=(a*a+b*b-c*c)/(2*a*b);
Write('cosA=',cosA,', cosB=',cosB,', cosC=',cosC)
end.
Тестовое решение
Введите a,b,c: 15.3 8 14.2
cosA=0.138864436619718, cosB=0.855495719414526, cosC=0.393995098039216