В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ayka557
Ayka557
18.03.2020 01:44 •  Информатика

Напишите программу на c#, которая запрашивает с клавиатуры четыре целых числа и выводит на экран таблицу, в которой для каждого из этих чисел выводится его модуль, квадратный корень и значение в четвертой степени. при выводе нецелых значений выводите два знака после запятой.

Ответ:
Elvirashka
Elvirashka
07.08.2020 22:59
Yaaas, я дождался C#, надеюсь что еще нужно

Console.WriteLine("Введите первое число: ");
int a = Convert.ToInt32(Console.ReadLine()); //первое число, спс, кэп
Console.WriteLine("Введите второе число: ");
int b = Convert.ToInt32(Console.ReadLine()); // второе число
Console.WriteLine("Введите третье число: ");
int c = Convert.ToInt32(Console.ReadLine()); // третье число
Console.WriteLine("Введите четвертое число: ");
int d = Convert.ToInt32(Console.ReadLine()); // четвертое число

int [] mass = new int {a, b, c, d}; // заносим числа в массив

for (int i = 0; i < mass.Length; i++) //пробегаем по массиву
{
    int module = Math.Abs(mass[i]); // находим модуль
    int koren = Math.Sqrt(mass[i]); // находим корень
    int stepen = Math.Pow(mass[i], 4); // находим 4 степень
    Console.WriteLine( Math.Round(mass[i], 2) + " " + Math.Roubnd(module, 2) +  " " + Math.Round(koren, 2) +  " " + Math.Round(stepen, 2) + "\n"); // выводим таблицу. \n - перенос на следующую строку
}

Если что, то не проверял запускается она или нет, лень VS включать. Но по идее все так должно быть.
Если что - пиши. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?