В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
изу197
изу197
24.05.2023 12:52 •  Информатика

Не могу составить программу, уже весь мозг перевернул, через pascal присвоить целой переменной d четвертую от конца цифру в записи положительного целого числа x (например, если x=34517, то d=4)

Ответ:
Nurs147
Nurs147
30.09.2020 06:04
Program Project;
uses
  crt;
var
  x,d: integer;
begin
  clrscr;
  write('x=');
  readln(x);
  d:=(x div 1000) mod 10;
  writeln('d=',d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?