В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kikimora16
Kikimora16
10.02.2021 02:02 •  Информатика

9класс напишите программу в паскале/делфи (без разницы) подсчета суммы: 1)1/2+(1*2)/4+(1*2*3)/6+ и т.д 2)(x-4)/4^1 + (x+8)/8^2 + (x-12)/12^3 + и т.д 3)4/2+8/2^2+16/2^3+ и т.д

Ответ:
MaxKryaks
MaxKryaks
30.09.2020 00:44
Var
    i, n, temp: integer;
    s, x: real;

begin
    read(n, x);
    s := 0;
    temp := 1;
    for i := 1 to n do
    begin
        temp := temp * i;
        s := s + temp / (2 * i);
    end;
    writeln(s);
    
    s := 0;
    temp := 1;
    for i := 1 to n do
    begin
        temp := temp * (-1);
        s := s + (x + temp * 4 * i) / exp(i * ln(4 * i));
    end;
    writeln(s);
    
    s := 0;
    for i := 1 to n do
    begin
        s := s + 2;
    end;
    writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?