В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
khabarova84
khabarova84
22.12.2022 02:43 •  Информатика

Написать программу в паскале . вводим два числа. компьютер должен вывести квадратное уравнение,корнями которого являются эти два числа. (использоват теорему виета)

Ответ:
onaleman
onaleman
03.10.2020 19:16
Var x1,x2,p,b:real;
begin
readln(x1,x2);{Вводим два числа}
p:=x1+x2;{Вычисляем значение коэффициента при х}
b:=x1*x2;{Вычисляем значение свободного слагаемого}
if p>0 then{Проверка на знак полученных значений и вывод уравнения, как проще сделать со знаком, увы не знаю}
begin
if b>0 then
writeln('x^2-',p,'x+',b,'=0')
else
writeln('x^2-',p,'x-',abs(b),'=0');
end
else
begin
if b>0 then
writeln('x^2+',abs(p),'x+',b,'=0')
else
writeln('x^2+',abs(p),'x-',abs(b),'=0');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?