В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Мамкинс
Мамкинс
02.11.2022 02:16 •  Информатика

Напишите программу на языке паскаль, которая в конце выведет среднемесячную температуру.

Ответ:
MARCOM03
MARCOM03
28.09.2020 22:57
Const n=30;
var a : array[1..n] of integer;
    sum,i : integer;
begin
Randomize;
for i:=1 to n do
 begin
  a[i]:=random(20)+10;
  write(a[i],' ');
 end;
writeln;
sum:=0;
for i:=1 to n do sum:=sum+a[i];
writeln('Среднемесячная температура = ',sum/n);
end.

Пример (для n=10):
15 22 27 20 23 13 23 25 29 26 
Среднемесячная температура = 22.3
0,0(0 оценок)
Ответ:
мотя105
мотя105
28.09.2020 22:57
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?