В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Girjd
Girjd
03.05.2021 11:49 •  Информатика

Добрый день. нужна в паскале. необходимо составить программу подсчёта количества нулевых элементов в массиве а(100). буду премного .

Ответ:
artemkharlamov1
artemkharlamov1
28.09.2020 20:21
Const
  n=100; { размер массива }
var
  a:array[1..n] of integer;
  i,k:integer;
begin
  { заполняем массив случайными значениями }
  Randomize;
  k:=0;
  Writeln('Элементы массива');
  for i:=1 to n do
    begin
    a[i]:=Random(41)-20;
    Write(a[i],' ');
    if a[i]=0 then Inc(k)
    end;
  Writeln;  
  Writeln('Нулевых элементов: ',k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?