В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
thefirststudent
thefirststudent
14.09.2020 22:57 •  Информатика

Написать программу в pascal abc для вычисления среднего гармонического значения элементов массива х (n), кратных двум. при этом даны ограничения, что xi> 0, n< 30. n должно выбираться через генератор случайных чисел random и randomize.

Ответ:
Ева671
Ева671
28.09.2020 15:21
Var
    a: array[1..100] of integer;
    i, n: integer;
    harmonic: real;
    k: integer;

begin
    Randomize;
    n := random(20) + 10;
    
    for i := 1 to n do
    begin
        a[i] := random(50);
        write(a[i], ' ');
    end;
    writeln();
    
    harmonic := 1;
    k := 0;
    for i := 1 to n do
    begin
        if a[i] mod 2 = 0 then {фильтр}
        begin
            harmonic := harmonic + 1 / a[i];
            k := k + 1;
        end;
    end;
    writeln('harmonic mean = ', k / harmonic);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?