В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
myasovkavlad
myasovkavlad
08.06.2020 09:30 •  Информатика

Нужно написать программу на pascalabc. вводится n чисел, найти максимальное двузначное среди них.

Ответ:
vipborisov200
vipborisov200
21.09.2020 12:23
Var
  n,max,i,a : longint;
begin
  readln(n); {количество чисел}
  max:=0; {чтобы вывести 0 если нет двухзначных}
  for i:=1 to n do
    begin
      readln(a); {хранить массив не надо т.к. он нигде не требуется}
      if (a>9) and (a<100) and (a>max)
        then max:=a;
    end;
  if max>0
    then writeln(max)
    else writeln('нет двухзначных чисел')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?