Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
theknow14
15.08.2022 06:37 •
Информатика
Вычислить 20! + 30! используя паскаль. желательно показывая формулу. ато подзабыл тему
Ответ:
Snupian
03.10.2020 18:28
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
function F(n:biginteger):biginteger;
begin
if n<=1 then Result:=1
else begin
Result:=1;
var i:biginteger:=1;
while i<=n do begin Result*=i; i+=1 end;
end
end;
begin
Writeln(F(20)+F(30))
end.
Результат
265252859812193491538316656640000
0,0
(0 оценок)
Популярные вопросы: Информатика
vovastepochkin
25.02.2020 05:53
Решить и по возможности обьясните как это решается(( найдите значения выражений. (1v1)v(1v0) , )v1)v1)...
dimalol3373
25.02.2020 05:53
Задан массив а из n элементов. заменить в нём каждый элемент полусуммой предыдущего и последующего, если n=0 то заменить на второй, а если последний равен 0 то заменить...
artem190909
03.01.2021 21:42
Вычислить значение каждых вторых элементов последней трети массива” код программы есть,нужно только указать, чтобы она выбирала каждый второй элемент.,: procedure part_2(n:...
ArturGafiyatullin145
03.01.2021 21:42
Какие параметры форматирования вы знаете? , !...
kristina150017584969
24.06.2022 03:59
Объясните : с клавиатуры вводится трёхзначное число. написать программу, которая составляет новое трёхзначное число, в котором цифры десятков и сотен поменяли местами....
irunahruha
16.11.2022 20:19
Для каких целей используется мультимедийный проектор?...
TheLoneRider
22.04.2022 00:00
Ms excel протабулировать эту функцию...
gasdgg
04.12.2020 04:03
Для чего нужно определять объем информации...
DISTANOV
14.08.2021 05:38
:нарисовать вертикальные линии с начальной координатой (10, 10), длиной линий (l), количеством линий (n) и шагом step. сделать эту по теме организация циклов в программе...
KristheMalen
27.03.2020 19:06
В координатной системе даны точки A(−3;0;−7) и B(−1;2;−5). Определи координаты точки M на координатной оси Oz, которая находится на равных расстояниях от данных точек A...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
function F(n:biginteger):biginteger;
begin
if n<=1 then Result:=1
else begin
Result:=1;
var i:biginteger:=1;
while i<=n do begin Result*=i; i+=1 end;
end
end;
begin
Writeln(F(20)+F(30))
end.
Результат
265252859812193491538316656640000