В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Объясните : с клавиатуры вводится трёхзначное число. написать программу, которая составляет новое трёхзначное число, в котором цифры десятков и сотен поменяли местами. заранее большое !

Ответ:
caxopo4ek
caxopo4ek
07.06.2020 22:53

Объяснение:

тут есть маленькая хитрость

Если записать число не как число а как строку то оно будет восприниматься как слово.

program bred;

var

x :string;

begin

writeln('Введите число': );

readln(x);           -    мы получаем число

writeln(x[2],x[1],x[3]); - указываем какую цифру мы берем и на какое место ставим

end.

Все! Удачи! Отметь этот ответ лучшим!

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?