В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Решить! 1.с repeat напишите программу,которая требует у вас пароль,например 111. если пароль правильный,то заполняет все строки экрана сообщением "молодец". если после пятой попытки пароль всё равно неверен,выходит из программы.( я составил программу,но как ограничить её 5-ю попытками,не знаю). 2.составьте программу,вычисляющую а*в,не пользуясь операцией умножения. а и в любое натуральное число. 3.каждая бактерия делится на две в течение одной минуты. в начальный момент имеется одна бактерия. составьте программу,которая рассчитывает количество бактерий на заданное вами целое значение момента времени(15 минут,7 минут и т п.) 4. в 1202г. итальянский леонард пизанский (фибоначчи) предложил такую : пара кроликов каждый месяц дает приплод – двух кроликов (самца и самку), от которых через два месяца уже получается новый приплод, сколько кроликов будет через год, если в начале года имелась одна пара? согласно условию числа, соответствующие количеству кроликов, которые появляются через каждый месяц, составляют последовательность 1, 1, 2, 3, 5, 8, 13, 21, 37, … составьте программу, позволяющую найти все числа фибоначчи, меньшие заданного числа n.

Ответ:
AlexanderVard
AlexanderVard
31.07.2020 21:46
Var X,n: integer;beginn:=0;repeat Write ('Значение X= '); Readln (X); if X <> 111 then//until X = 111;Writeln ('Пароль неверный!')else writeln('Молодец!');inc(n);
until (x=111) or (n=5);if n=5 then writeln('Максимум 5 попыток');end.
0,0(0 оценок)
Ответ:
Вторая задача
var a,b,i,sum:integer;beginread(a,b);for i:=1 to b do begin   inc(sum,a);   end;writeln(sum);end.
Третья задача.
var a,b,i,sum:integer;beginwriteln('Cколько минут
Четвертая задача
var a,i,x:integer;    fibb:array [0..1000] of integer;beginread(a);fibb[0]:=1;fibb[1]:=1;i:=2;while fibb[i-1]<a do begin    fibb[i]:=fibb[i-1]+fibb[i-2];    inc(i);    end;x:=i;for i:=1 to x-2 do beginwrite(fibb[i],' ');end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?