В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zkudaybergen
zkudaybergen
29.06.2022 17:39 •  Информатика

Составить программу для pascal abc, печатающую значение true, если указанное высказывание является истинным, и false в противном случае, когда данная тройка натуральных чисел a, b, c является тройкой пифагора, т.е. c^2 = a^2 + b^2.

Ответ:
kycokbatona
kycokbatona
28.05.2020 10:21

uses crt;
var
t1:boolean;
a, b, c: integer;
begin
readln(a, b, c);
if c*c=a*a+b*b then t1:= true else t1:= false;
writeln (t1);
readkey;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?