В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Дима566779
Дима566779
06.01.2021 15:45 •  Информатика

ОТ Дан одномерный целочисленный массив. Количество элементов массива не может превышать 1000. Пользователь вводит количество элементов и сами элементы на вход программы. Найти количество элементов массива, которые больше 70, вывести его на экран.

Написать программу для решения задачи из прикрепленного файла. Фотографию кода программы прикрепить в домашнем задании. Допускается как электронный вариант (фото готовой программы в среде программирования), так и фото написанного от руки кода в тетради .​

Ответ:
lika1vulvach
lika1vulvach
15.01.2021 21:32

Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно. Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, в которых сумма элементов делится на 2, но не делится на 4. В данной задаче под парой подразумеваются два соседних элемента массива.

Исходные данные объявлены так, как показано ниже на примерах для некоторых языков программирования. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать некоторые из описанных переменных.

Бейсик Python

CONST N = 20

DIM A (1 TO N) AS INTEGER

DIM I, J, K AS INTEGER

FOR I = 1 TO N

INPUT A(I)

NEXT I

END

// допускается также использовать

// две целочисленные переменные

// j и k

a = []

n = 20

for i in range(0, n):

a.append(int(input()))

Паскаль Алгоритмический язык

const

N = 20;

var

a: array [1..N] of

integer;

i, j, k: integer;

begin

for i := 1 to N do

readln(a[i]);

end.

алг

нач

цел N = 20

целтаб a[1:N]

цел i, j, k

нц для i от 1 до N

ввод a[i]

кц

кон

Си++

#include

#define N 20

int main() {

int a[N];

int i, j, k;

for (i = 0; i < N; i++)

cin >> a[i];

return 0;

}

В качестве ответа Вам необходимо привести фрагмент программы, который должен находиться на месте многоточия. Вы можете записать решение также на другом языке программирования (укажите название и используемую версию языка программирования, например, Free Pascal 2.6). В этом случае Вы должны использовать те же самые исходные данные и переменные, какие были предложены в приведённых фрагментах.

Решение · Поделиться · Курс · Сообщить об ошибке

2

Задания Д25 C2 № 7709

Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно. Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, в которых сумма элементов делится на 3, но не делится на 9. В данной задаче под парой подразумеваются два соседних элемента массива.

Исходные данные объявлены так, как показано ниже на примерах для некоторых языков программирования. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать некоторые из описанных переменных.

Бейсик Python

CONST N = 20

DIM A (1 TO N) AS INTEGER

DIM I, J, K AS INTEGER

FOR I = 1 TO N

INPUT A(I)

NEXT I

END

// допускается также использовать

// две целочисленные переменные

// j и k

a = []

n = 20

for i in range(0, n):

a.append(int(input()))

Паскаль Алгоритмический язык

const

N = 20;

var

a: array [1..N] of

integer;

i, j, k: integer;

begin

for i := 1 to N do

readln(a[i]);

end.

алг

нач

цел N = 20

целтаб a[1:N]

цел i, j, k

нц для i от 1 до N

ввод a[i]

кц

кон

Си++

#include <iostream>

#define N 20

using namespace std;

int main() {

int a[N];

int i, j, k;

for (i = 0; i < N; i++)

cin >> a[i];

return 0;

}

В качестве ответа Вам необходимо привести фрагмент программы, который должен находиться на месте многоточия. Вы можете записать решение также на другом языке программирования (укажите название и используемую версию языка программирования, например, Free Pascal 2.6). В этом случае Вы должны использовать те же самые исходные данные и переменные, какие были предложены в приведённых фрагментах.

Решение · Поделиться · Курс · Сообщить об ошибке

3

Задания Д25 C2 № 7770

Дан целочисленный массив из 40 элементов. Элементы массива могут принимать целые значения от –100 до 100 включительно. Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, произведение которых положительно, а сумма кратна 7. Под парой подразумевается два подряд идущих элемента массива. Исходные данные объявлены так, как показано ниже на примерах для некоторых языков программирования и естественного языка. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать некоторые из описанных переменных.

Бейсик Паскаль

N = 40

DIM A(N) AS LONG

DIM I, J, K AS LONG

FOR I = 1 TO N

INPUT A(I)

NEXT I

...

END

const

N = 40;

var

a: array [1..N] of longint;

i, j, k: longint;

begin

for i := 1 to N do

readln(a[i]);

...

end.

Си++ Алгоритмический язык

#include

#define N 40

int main()

{

long a[N];

long i, j, k;

for (i = 0; i < N; i++)

cin >> a[i];

...

}

алг

нач

цел N = 40

цел таб a[1:N]

цел i, j, k

нц для i от 1 до N

ввод a[i]

кц

...

кон

Естественный язык

Объявляем массив A из 40 элементов.

Объявляем целочисленные переменные I, J, K.

В цикле от 1 до 40 вводим элементы массива A с 1-го по 40-й.

...

Python

// допускается также использовать

// две целочисленные переменные

// j и k

a = []

n = 40

for i in range(0, n):

a.append(int(input()))

В качестве ответа Вам необходимо привести фрагмент программы, который должен находиться на месте многоточия. Вы можете записать решение также на другом языке программирования (укажите название и используемую версию языка программирования, например, Free Pascal 2.6). В этом случае Вы должны использовать те же самые исходные данные и переменные, какие были предложены в приведённых фрагментах.

0,0(0 оценок)
Ответ:
akrasnoplakhtyc
akrasnoplakhtyc
15.01.2021 21:32

C++

Объяснение:

#include <iostream>

using namespace std;

const int maxCount = 1000;

int main() {

int i, count;

int *arr;

 

cout << "Input count elements: ";

cin >> count;

 

if(count <= maxCount) {

 arr = new int[count];

 

 int st = 0;

 

 cout << "Input elements array" << endl;

 

 for(i = 0;i < count;i++) {

  cin >> arr[i];

  if(arr[i] > 70) {

   st++;

  }

 }

 

 cout << "Result: " << st;

}  

else {

 cout << "Error!" << endl;

}

 

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?