В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
stovolosova03
stovolosova03
10.10.2021 15:51 •  Информатика

Напишите программу, которая определяет максимальное значение среди введенных чисел до нуля

Ответ:
12345578824828
12345578824828
16.09.2020 01:52
Как я понял, 0 - условие окончания ввода последовательности. Тогда может получиться так:
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,max:integer;
begin
  max:=-MaxInt;
  repeat
    readln(a);
    if a>max then max:=a;
  until a=0;
  writeln('max = ',max);
end.

Тестовое решение:
25
11
43
34
23
65
12
36
0
max = 65
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?