Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
shah25
10.05.2020 13:15 •
Информатика
Напишите программу которая вычисляет дискрименант квадратного уравнения (в паскале)
Ответ:
vitalinabelova1
03.10.2020 13:47
Var a,b,c,d:integer;
begin
writeln('Введите коэффициенты a, b, c:');
readln(a,b,c);
d:=b*b-4*a*c;
writeln('D = ',d);
end.
Пример:
Введите коэффициенты a, b, c:
5 2 8
D = -156
0,0
(0 оценок)
Ответ:
00000000000000000020
03.10.2020 13:47
У тебя написано только дискриминант. Я написал, но мне кажется тебе нужны были корни
Var a,b,c,d:integer;
begin
read(a,b,c);
d:=b*b-4*a*c;
writeln(d);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
damilya12sladcoeshka
08.08.2020 00:48
Яке значення функції если (8 2; сумм(2; 8); макс(2; 8))...
vgfhdijubvn
12.08.2022 19:34
Рассмотрите следующее описание функции: function f(x: integer): integer; begin if x =10 then f: =1 else f: =f(f(x-1)) end; каким будет значение f(10)?...
Аружан200345
21.05.2023 15:45
(24 mod 5-16 div 2)* trunc(-5.2)/ abs(trunс(-6.8)+round(-6.8))...
gleb21717
21.05.2023 15:45
Составьте программу нахождения трёхзначного числа , куб суммы цифр которого равен ему самому...
Darina784
21.05.2023 15:45
Составить программу выводящую на экран сумму всех чётных чисел в промежутке от 12 до 30...
VolhaRednaya8
18.12.2021 04:39
Документ объёмом 30мбайт можно передать с одного компьютера на другой двумя вариантами: а. сжать архиватором, передать архив по каналу связи, распаковать. б. передать по каналу...
nogood2
18.12.2021 04:39
Представь себе, что ты машинист, ведущий поезд из москвы в санкт-петербург всего в составе поезда 13 вагонов в поезде обслуживание 30 человек начальнику поезда 46 лет кочегар на...
раиль33
12.05.2020 04:37
1 Сойлемди толыктырыныз Багдарламалау жуйелери- Багдарламалау тилдери- ...
katizh
10.10.2020 10:38
Дан фрагмент кода z=0 for x in range(7) z=x. сколько раз выполнится циклответы: 49 0 5 7 ...
532настя43510
10.01.2022 21:35
Задача 4 Спортсмен Василий участвовал в соревнованиях по хоккейболу и получил в личном зачете серебряную медаль. Известно, что участники, получившие одинаковое количество очков,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
writeln('Введите коэффициенты a, b, c:');
readln(a,b,c);
d:=b*b-4*a*c;
writeln('D = ',d);
end.
Пример:
Введите коэффициенты a, b, c:
5 2 8
D = -156
Var a,b,c,d:integer;
begin
read(a,b,c);
d:=b*b-4*a*c;
writeln(d);
end.