В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gleb21717
gleb21717
21.05.2023 15:45 •  Информатика

Составьте программу нахождения трёхзначного числа , куб суммы цифр которого равен ему самому

Ответ:
апнг1
апнг1
26.05.2020 00:04

var
a,b,c,n:integer;
begin
for n:=100 to 999 do
begin
a:= n div 100;
b:= n div 10 mod 10;
c:= n mod 10;
if (a+b+c)*(a+b+c)*(a+b+c)=n then writeln(n);
end;
end.

 

и в результате получаем, что это число 512

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?