Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
сонясонясоня1
14.04.2020 22:13 •
Информатика
Составить программу 1. нужна программа на тему алгоритма евклида, составьте ,чтобы в паскаль её забить. программа для нахождения наибольшего общего делителя.
Ответ:
Meshnyakova52
24.09.2020 12:07
//Pascal ABC.NET v3.1 сборка 1172
var
a, b, nod: integer;
begin
read(a, b);
while a * b <> 0 do
if a > b then a := a mod b
else b := b mod a;
nod := a + b;
writeln(nod);
end.
Пример ввода:
1071
462
Пример вывода:
21
0,0
(0 оценок)
Популярные вопросы: Информатика
ksushadream1
07.07.2022 22:27
Составьте программу: задать массив из 10 чисел, заданных с генератора случайных чисел, найти в нем максимальный элемент (привести лишь функцию main)...
Arianalike
12.11.2022 07:51
Феофилакт хочет купить ракетки и шарики для игры в настольный теннис. Один комплект ракеток стоит A рублей, один шарик стоит B рублей. У Феофилакта есть C рублей, C≥A, он...
a01065699799
05.09.2020 09:42
В 16384 бите сколько байтов и сколько килобайтов?...
reginaarslanov
16.02.2021 06:43
На заводе запустили новую производственную линию по изготовлению автомобильных двигателей. На этапе тестирования объем выпущенной продукции каждый день удваивался. Выполнение...
Dragolord
11.05.2023 01:35
Вчем ошибка? обычный батник в котором надо вкл и вывести сообшение мир chcp 1251 @echo off color 0c echo мир pause;...
Дллллллллллл
01.11.2020 22:45
Аня написала все целые числа в промежутке (65; 101) в восьмеричной системе счисления. ваня стер все числа, содержащие цифру 7. найдите сумму оставшихся чисел в восьмеричной...
Zxcvvn
14.11.2022 03:21
Пишет: ошибка. программа завершена из за переполнения стека. паскаль. , . вот программа: program alisa_5; const n=10; var i: integer; a: array [ 1 .. n] of integer; procedure...
Покемон123456789
22.05.2023 19:18
Берілген сын есімдерді қатыстырып,сөйлем құра : мейрімді,инабатты,жуас...
Татьяна4222
12.09.2021 22:28
числительные: - пятьсот сорок три книги- сто девяносто пятый урок...
karinaklinaeva
12.09.2021 22:28
снег какой ? облака какие? ветер какой гроза какая?туман какой?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a, b, nod: integer;
begin
read(a, b);
while a * b <> 0 do
if a > b then a := a mod b
else b := b mod a;
nod := a + b;
writeln(nod);
end.
Пример ввода:
1071
462
Пример вывода:
21