В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ksushadream1
ksushadream1
07.07.2022 22:27 •  Информатика

Составьте программу: задать массив из 10 чисел, заданных с генератора случайных чисел, найти в нем максимальный элемент (привести лишь функцию main)

Ответ:
Никольнейв
Никольнейв
13.10.2020 20:43

signed main() {

   const ll n = 10;

   srand(time(NULL));

   ll a[n];

   ll mx = -LLONG_MAX;

   for(ll i = 0; i < n; i++){

       a[i] = rand() % 100;

       mx = max(mx,a[i]);

   }

   cout << mx;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?