Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
cactuscus
28.03.2021 19:45 •
Информатика
Составить программу нахождения суммы трехзначных чисел кратных 5 и 7 и 9
Ответ:
лулу36
25.08.2020 13:48
//Pascal ABC.NET v3.1 сборка 1172
//Продвинутый вариант
begin
writeln(range(100,999).Where(x -> x mod 7=0).Where(x -> x mod 9=0).Where(x -> x mod 5=0).Sum);
end.
//"Школьный" вариант
Var
i,s:integer;
begin
for i:=100 to 999 do
if (i mod 5=0) and (i mod 7=0) and (i mod 9=0) then s:=s+i;
writeln(s);
end.
Вывод:
1890
0,0
(0 оценок)
Популярные вопросы: Информатика
3108200614041976
19.03.2022 06:42
Середовище виконання : IDLE (Python) Задача 1. Створити програму, яка при введенні будь-якого числа визначає, чи входить дане число у проміжок (-25; -5)Ụ(5;25) та виводить...
mahinaboboeva
08.01.2022 13:26
1. В каком меню находится Кнопка Гиперссылка ?*ВставкаГлавнаяСсылкиРассылки...
MariyaSavinkova
11.02.2022 02:35
Составить программу, которая определяет код введенного с клавиатуры символа s и m...
elenaveruaskina
19.03.2020 20:46
Каким именем лучше назвать дочку? Павла, Яна, Ассоль...
попаоп
01.07.2021 15:04
Як називався корабель який придбав Грей? ...
1Max8
26.12.2022 00:21
с объячнением ПОДРОБНО ФОРМ....
LIBOVALEmail
27.09.2021 00:30
2. Чому рослинність і тваринний світ пустель бідні?...
ivkn1401
27.09.2021 00:30
Подчеркните сказуемое, определите время, перевод, напишите отрицание, задайте вопрос, начиная со слов в скобках. 1. By 9 o’clock yesterday my grandmother had washed...
Мадина1111111112
13.04.2023 20:34
Боковая сторона равнобедренного треугольника равна 5 , радиус описанной окружности равен 25/6 . Найдите длину основания треугольника....
1234мика
12.11.2021 06:44
Короткий переказ ціеї фрази: гуде ліс,сухо подзвогюють мідним листом дуби, співають сосни у високості, під ногами вислизають тугі, мов литі, жолуді.Солодко пахне прілим...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
//Продвинутый вариант
begin
writeln(range(100,999).Where(x -> x mod 7=0).Where(x -> x mod 9=0).Where(x -> x mod 5=0).Sum);
end.
//"Школьный" вариант
Var
i,s:integer;
begin
for i:=100 to 999 do
if (i mod 5=0) and (i mod 7=0) and (i mod 9=0) then s:=s+i;
writeln(s);
end.
Вывод:
1890