Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
ilonaLoshakevic
07.09.2021 18:35 •
Информатика
Написать программу, которая в зависимости от введенного числа к, выполняет разные действия. если число отрицательное или не делится на 4, то |k+5|, иначе k²+5.
Ответ:
autosteklo777
31.07.2020 18:50
Var k:integer;
begin
writeln('введите число k');
readln(k);
if (k<0) or (k mod 4 <> 0) then writeln(abs(k+5))
else writeln(sqr(k)+5);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
lov3snake
30.06.2020 08:18
вводим с клавиатуры число ,если оно меньше -5 или больше 5 вывести на экран символ ,,$ иначе,,@...
imuraveva
09.10.2020 06:54
Дан рекурсивный алгоритм: procedure f(n: integer); begin writeln( * ); if n 0 then begin writeln( * ); f(n-2); f(n-2); f(n div 2); end end; сколько символов звездочка...
alenamon
19.10.2021 05:30
Найти произведение: \frac{(k^{2} +3)( k^{2}+5)( k^{2} +7)**( k^{2}+103) }{(k-7)(k-10)(k-13)**(k-97)} [/tex]...
tori201512
27.11.2022 19:36
Выпишут имена объектов (честен компьютера)в схему (номер 4 )...
KekalolQ
05.08.2021 19:38
В магазине купили перчатки,портфель,галстук. Составить программу на языке Паскаль, которая будет считать сумму всей покупки и выводить на экране фразу Покупка стоит...
lavbi3
29.02.2020 05:38
кто может с тестом по информатике, там ещё много заданий кому не сложно...
Yarik200825
02.07.2021 14:38
Сколько страниц текста можно записать на 20 мбайтах, если на одной странице 40 строк по 60 символов?...
smirnovadara747
09.04.2020 05:29
Найти информацию о нарушении формы скелета искревление позвоночника и плоскостопие....
alenas000
09.04.2020 05:29
Электронные и структурные формулы молекул следующих веществ: cl2, hf, h2s, ph3...
глаголица545
09.04.2020 05:29
Напишите рассказ по данному началу: иду я однажды по улице и...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
writeln('введите число k');
readln(k);
if (k<0) or (k mod 4 <> 0) then writeln(abs(k+5))
else writeln(sqr(k)+5);
end.