Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
даша3646
09.01.2023 02:02 •
Информатика
Напишите подпрограмму которая возвращает минимальное и максимальное значение из двух целых чисел a и b при следующих формул. min(a,b)=a+b-(a-b)/2 max(a,b)=a+b+(a-b)/2
Ответ:
Айхан11111111
24.09.2020 07:28
Var a,b:integer;
procedure min(x,y:integer);
begin
writeln(x+y-(x-y)/2);
end;
procedure max(x,y:integer);
begin
writeln(x+y+(x-y)/2);
end;
begin
writeln('Введите A,B');
readln(a,b);
write('min(',a,',',b,') = '); min(a,b);
write('max(',a,',',b,') = '); max(a,b);
end.
Тестовое решение:
Введите A,B
5 8
min(5,8) = 14.5
max(5,8) = 11.5
Введите A,B
9 4
min(9,4) = 10.5
max(9,4) = 15.5
0,0
(0 оценок)
Популярные вопросы: Информатика
DanielKanafiev
12.07.2020 09:43
Часть пищевой цепи в лесу можно описать так: 1) растения используют энергию солнца. 2) насекомые едят растения. 3) птицы едят насекомых. 4) лисы едят птиц. 5) но лисы также едят...
варяг2
08.04.2020 05:20
Только нужно решить не через if, a через case1. пользователь вводит неотрицательное однозначное число a. написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом...
каринка191
08.10.2021 17:55
Решить ребус на паскале, : a+ab+abc=bcb...
milana6164
08.10.2021 17:55
Написать программу чтоб работала в pascal запрашивает с клавиатуры три произвольных числа и выводит на экран сообщение о том, сколь-ко из них отрицательных, положительных и нулевых....
aaaaaaaahhh
08.10.2021 17:55
Написать программу чтоб работала в pascal запрашивает с клавиатуры два целых числа, их разность и частное (результат деления) и выводит на экран сообщение о правильности сделанных...
данданн
08.10.2021 17:55
Как представлено число 83,55510 в двоичной системе счисления с шестью знаками после запятой?...
Yulia190978
10.08.2021 10:04
1.какие диаграммы называют внедренными? 2. из каких шагов состоит процесс создания диаграмм? 3. какую зависимость отображают графики? 4. что понимают под биржей диаграммы?...
135Солнышко135
07.04.2023 16:59
Напишите программу языком бэйсик напечатать таблицу соответствия между квадратными метрами и гектарами для значений от 0.5 га до 6.5 га с шагом 0.5га...
artemkharlamov1
07.04.2023 16:59
Люди я вас умоляю ! ( a & ¬ b ) v c построить логическую не таблицу истинности...
ch32
20.01.2020 22:07
опишите, с какой целью выполняется шифрование данных.1 причина -2 причина - ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
procedure min(x,y:integer);
begin
writeln(x+y-(x-y)/2);
end;
procedure max(x,y:integer);
begin
writeln(x+y+(x-y)/2);
end;
begin
writeln('Введите A,B');
readln(a,b);
write('min(',a,',',b,') = '); min(a,b);
write('max(',a,',',b,') = '); max(a,b);
end.
Тестовое решение:
Введите A,B
5 8
min(5,8) = 14.5
max(5,8) = 11.5
Введите A,B
9 4
min(9,4) = 10.5
max(9,4) = 15.5