В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
milana6164
milana6164
08.10.2021 17:55 •  Информатика

Написать программу чтоб работала в pascal запрашивает с клавиатуры три произвольных числа и выводит на экран сообщение о том, сколь-ко из них отрицательных, положительных и нулевых.

Ответ:
нури43
нури43
01.10.2020 19:12
PascalABC
var x,y,z:real;
k,m,n:integer;
begin
k:=0;
m:=0;
n:=0;
writeln('Введите первое  число');
readln(x);
writeln('Введите второе  число');
readln(y);
writeln('Введите третье число');
readln(z);
if x>0 then k:=k+1
else if x=0 then m:=m+1
else n:=n+1;
if y>0 then k:=k+1
else if y=0 then m:=m+1
else n:=n+1;
if z>0 then k:=k+1
else if z=0 then m:=m+1
else n:=n+1;
writeln('Количеcтво положительных чисел : ',k);
writeln('Количеcтво нулевых чисел : ',m);
writeln('Количеcтво отрицательных чисел : ',n);
end.
0,0(0 оценок)
Ответ:
199535
199535
01.10.2020 19:12
Program pr; var a,b,nul,otr,pol,c:integer; begin write('A='); readln(a); write('B='); readln(b); write('C='); readln(c); if a>0 then pol:=pol+1 else if a=0 then nul:=nul+1 else otr:=otr+1; if b>0 then pol:=pol+1 else if b=0 then nul:=nul+1 else otr:=otr+1; if c>0 then pol:=pol+1 else if c=0 then nul:=nul+1 else otr:=otr+1; writeln('Положительных: ',pol); writeln('Отрицательных: ',otr); writeln('Нулевых: ',nul); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?