В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Савелий187
Савелий187
22.01.2022 08:27 •  Информатика

Составьте программу, заменяющую больше из двух данных чисел удвоенным произведением, а меньшее - полусуммой этих чисел

Ответ:
wagnercop06s12
wagnercop06s12
24.09.2020 06:52
Var a,b,a1,b1:real;
begin
  readln(a,b);
  if a = b then writeln('Числа равны')
  else
    if a>b then begin
      a1:=2*a*b; b1:=(a+b)/2;
      a:=a1;b:=b1;
      writeln('a = ',a,' b = ',b)
    end
    else begin
      b1:=2*a*b; a1:=(a+b)/2;
      a:=a1;b:=b1;
      writeln('a = ',a,' b = ',b);
    end;
 end.
 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?