Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Kruglivnik1ta
22.09.2021 12:31 •
Информатика
Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа. паскаль
Ответ:
lena08m
23.09.2020 20:53
Var
n, s: integer;
begin
write('Число: ');
readln(n);
s := 0;
while n > 0 do
begin
s := s + n mod 10;
n := n div 10
end;
writeln('Сумма цифр = ', s);
end.
Тестовое решение:
Число: 12345
Сумма цифр = 15
0,0
(0 оценок)
Ответ:
nnxxxmm5p03cok
23.09.2020 20:53
На Java
http://pastebin.com/SbfSZLFK
ввод - 1234567890123456
вывод - 66
var n, sum: integer;
begin
readln(n);
sum := 0;
while n > 0 do begin
sum := sum + n mod 10;
n := n div 10
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
артем1488337
26.04.2020 06:21
Напишите комментарий каким типам данных объявленные переменные? int a; / / объявление а типаfloat b; / / double c = 14.2; / / char d = s ; / / bool k = true; / /...
xtreil181пингвинчик
12.02.2022 12:55
Самостоятельно придумайте примеры данных, которые можно организовать в виде массива. в каждом примере отметьте: каким именем можно обозначить массив, как пронумеровать...
влаласт
04.06.2023 10:13
Как называется раздел диалогового окна 7 букв четвёртая а (windows 7) !...
BeautifulGirl001
04.06.2023 10:13
Составить программу для решения . ввести любое число с клавиатуры. найти его квадрат, если число отрицательное, в противном случае найти квадратный корень....
artemivanyk200
04.06.2023 10:13
Перевести в десятичную число 840 подробнее...
polina030502
17.12.2021 13:54
В ячейке А1 находится формула. Формулу из ячейки А1 скопировали в ячейку А5. Выберите формулу, которая окажется после копирования ячейке А5: Возможные ответы ответы:...
sashafedorishyn
14.04.2023 17:07
Как пройди быстро шадол файт...
Nic5748796237067736
08.06.2020 05:44
2.ЗАДАНИЕ Представленный изобретателями на Всемирной конференции роботов в Пекине вавгусте 2019года робот-высококвалифицированный специалист выполнять сложные операции...
Знания
01.02.2022 14:40
2машины ехали из двух городов навстречу друг другу. первая машина ехала со скоростью 70 км/ч,а 2 на 20 км/ больше сколько километров между если они встретились через...
TimaWarface
01.02.2022 14:40
Сколько семян овса необходимо для посева на поле длиной 40 метров и шириной 20 метров если на 1 метр нужно 400 граммов риса...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n, s: integer;
begin
write('Число: ');
readln(n);
s := 0;
while n > 0 do
begin
s := s + n mod 10;
n := n div 10
end;
writeln('Сумма цифр = ', s);
end.
Тестовое решение:
Число: 12345
Сумма цифр = 15
http://pastebin.com/SbfSZLFK
ввод - 1234567890123456
вывод - 66
var n, sum: integer;
begin
readln(n);
sum := 0;
while n > 0 do begin
sum := sum + n mod 10;
n := n div 10
end;
writeln(sum);
end.