В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kirikk3
kirikk3
28.11.2021 04:07 •  Информатика

Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. используйте процедуру. программа должна вывести двоичное представление переданного её числа. примеры входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110

Ответ:
mashenkamini
mashenkamini
23.09.2020 07:28
Var n:integer; s:string;
procedure bin(n:integer; var s:string);
var i:integer; c:string;
begin
s:='';
while n>0 do
  begin
 STR(n mod 2,c);
 s:=c+s;
 n:=n div 2;
 end;
end;
begin
write('n='); readln(n);
bin(abs(n),s);
if n<0 then s:='-'+s;
writeln(s);
end.

Пример:
n=-14
-1110
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?