Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
АлинаБречко
02.01.2022 10:38 •
Информатика
Программа спрашивает вес некого объекта в килограммах, затем спрашивает, в какие единицы измерения перевести и делает это по выбору пользователя. (условный оператор)
Ответ:
milashka44
03.10.2020 09:13
Var s: string; k: real;
begin
write('Введите вес в килограммах ');
Readln(k);
Write('Во что хотите перевести (мгр, гр, Цн, Тн, КТн, МТн): ');
Readln(s);
case s of
'мгр': write(k, 'кг = ', k * 1000000, ' мгр');
'гр': write(k, 'кг = ', k * 1000, ' гр');
'Цн': write(k, 'кг = ', k / 100, ' ц');
'Тн': write(k, 'кг = ', k / 1000, ' Т');
'КТн': write(k, 'кг = ', k / 1000000, ' Кт');
'МТн': write(k, 'кг = ', k / 1000000000, ' Мт')
Else write('Неправильно введена единица измерения');
End;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ParkTaehyung
20.07.2022 21:45
Написать программу которая выводит на экран все отрицательные четные числа из диапазона a и b на паскале ...
katyaden2
20.03.2022 04:33
Водной из кодировок unicode каждый символ кодируется 16-ю битами.определите размер следующего предложение в данной кодировоке: отрицание дизъюнкции есть конъюнкция отрицаний....
LoL228LoL228LoL228
13.09.2022 18:01
Как называется программа, которая позволяет оформлять текст разными стилями и добавлять в документ рисунки и таблицы? варианты ответа: текстовый редактор графический редактор...
30kotenok04
18.08.2021 05:07
Кто захочет со мной дружить? если что вот мой номер 87472512235 я девочка 13 лет живу в казахстане...
ermolaeva1207Arina
21.01.2021 09:47
Көп нүктенің орнына қажетті сөздер мен сөз тіркестерін қойып жаз. Помагите...
sanzarerzanylu8
30.09.2020 20:43
Text 1. Welding & Machine Trades Welding is a skill used by many trades: sheet metal workers, ironworkers, diesel mechanics, boilermakers, carpenters, marine construction,...
Татьяна45512
18.05.2023 06:50
ДАМ ЛУЧШИЙ ОТВЕТЬ ПОСТАВЛЮ ЛАЙК И ПЯТЬ ЗВЁЗД И ПОДПИШУСЬ Мәтіндерден салт етістіктерді теріп жазыңдар және оларды сабақты етістікке айналдырыңдар...
bondarsvetlana25
14.08.2020 02:50
1 – тапсырма. Әңгіменің кейіпкерлеріне мінездеме жазыңыз. 2 – тапсырма. Оқушылар кейіпкер картасын толтырады: Кейіпкердің есімі Кейіпкерді суреттейтін 3 сөз Кейіпкердің...
Kok1n
29.09.2022 09:24
Не понимаю, что делать.. Выясните наибольшее значение выражения 3(5y^2−4)+(4y+3)(3−4y)...
Индира1973
25.07.2021 02:42
Это отрывок только. 1. Какова главная мысль рассказа Весенний дождь (Пивоваров.И)?2.Кто из героев произведения тебе понравился и почему?3.Какие поступки Люси ты одобряешь,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('Введите вес в килограммах ');
Readln(k);
Write('Во что хотите перевести (мгр, гр, Цн, Тн, КТн, МТн): ');
Readln(s);
case s of
'мгр': write(k, 'кг = ', k * 1000000, ' мгр');
'гр': write(k, 'кг = ', k * 1000, ' гр');
'Цн': write(k, 'кг = ', k / 100, ' ц');
'Тн': write(k, 'кг = ', k / 1000, ' Т');
'КТн': write(k, 'кг = ', k / 1000000, ' Кт');
'МТн': write(k, 'кг = ', k / 1000000000, ' Мт')
Else write('Неправильно введена единица измерения');
End;
end.