В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
faridudin
faridudin
22.02.2023 15:20 •  Информатика

Составьте программу заполнения массива из ста чисел, со случайными значениями из диапазона от -20 до 20. посчитайте в этом массиве количество положительный и отрицательных чисел.

Ответ:
Мадока2000
Мадока2000
03.10.2020 07:41
Const n=100;
var x : array[1..n] of integer;
   i,k1,k2 : integer;
begin
Randomize; 
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=random(41)-20; 
  write(x[i],' ');     
 end;
 writeln;
for i:=1 to n do
 begin
 if x[i]<0 then k1:=k1+1;
 if x[i]>0 then k2:=k2+1;
 end;
writeln('k1=',k1,'  k2=',k2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?