В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sorrypepemain
sorrypepemain
01.06.2020 14:15 •  Информатика

Написать программу на паскале дана строка символов.определить длину самого длинного слова и напечатать его. желательно написать программу с функции pos

Ответ:
moon65
moon65
03.10.2020 07:34
Var
Text, Slovo, max:string;
Begin    
WriteLn('Введите строку, разделенную пробелами: '); ReadLn(Tex); 
Text:= Text + ' ';    
max:='';    
While Pos(' ',Text) <> 0 do      
Begin      
Slovo:= Copy(Text, 1, Pos(' ',Text) - 1);      
Delete(Text, 1, Pos(' ',Text));      
if Length(Slovo) > Length(max)
then max:= Slovo;      
End;    
WriteLn('Самое длинное слово: " ',max,' " его длина ',Length(max));
ReadLn;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?