В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sasjaghf
Sasjaghf
27.04.2021 23:19 •  Информатика

Написать программу.известно,что x кг конфет - стоит a рублей.определить сколько стоит y кг этих же конфет,а так же сколько кг конфет можно купить на k рублей.все значения вводит пользователь

Ответ:
Danlika
Danlika
07.08.2020 09:47
Program konfeta;
uses crt;
var a,b,c,k:integer; 
   d,e,m:real;
begin 
clrscr; 
write('Input (x) weight: '); 
readln(b); 
write('Input (a) cost: '); 
readln(a); 
d:=a/b; 
write('1 kg cost ',d:2:2); 
writeln; 
write('Input (y)kg: '); 
readln(c); 
e:=c*d; 
writeln(c ,' kg cost= ',e:2:2); 
write('Input k rub: '); 
readln(k); 
m:=k/d; 
writeln(k ,' rub cost ',m:2:2 ,' kg.'); 
write('Press any key...'); 
repeat until 
keypressed;
end.

если надо пояснение пиши
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?