Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Jere558
16.11.2021 23:07 •
Информатика
Паскаль procedure f(n: integer); begin if n < = 5 then begin f(n + 2); writeln (n); f(n + 3) end end чему равна сумма всех чисел, напечатанных на экране при выполнении вызова f(l)? (и как)
Ответ:
KeKsickON
03.10.2020 06:04
ответ: 13.
А получается он вот так:
procedure F(n:integer);
begin
Writeln('Вызов F(',n,')');
if n <= 5 then begin
F(n + 2);
writeln('Процедура вывела ',n);
F(n + 3)
end
end;
begin
f(1)
end.
Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)
0,0
(0 оценок)
Популярные вопросы: Информатика
erasildamir
16.08.2021 03:09
Решите по информатике чёрно-белая картина построена на экране монитора, с разрешением 800×600 какой объём памяти она занимает?...
женя1378
16.08.2021 03:09
шифр цезаря .этот шифр реализует следующее преобразование текста: каждая буква исходного текста заменяется третьей после неё буквой в алфавите,который считается написанным...
lizismik15
16.08.2021 03:09
Напишите программу для решения определить является ли данное число n чётным двухзначным числом...
OBOShh
16.08.2021 03:09
На вокзале 4 платформы, у каждой из них стоит поезд. девушка в справочном окне отвечает на все вопросы только «да» и «нет». за какое минимальное число вопросов можно гарантированно...
kjmhngbfv
16.08.2021 03:09
Составить программу, вычисления стоимости поездки на машине, вид экрана во время выполнения программы следующий: расстояние до пункта 61 км расход горючего 8, 5л цена литра...
5Костя5
16.08.2021 03:09
Сформулируйте алгоритм вычисления y по формуле y=(2x+-5)...
kostsimonof
24.02.2021 21:26
Выберите, в каком из примеров единицы измерения представлены в порядке убывания: а) 3 кбайт, 3076 байт, 58 бит, 50 бит, 6 байт б) 3076 байт, 3 кбайт, 58 бит, 50 бит, 6 байт...
slavinka17
27.07.2022 22:11
Втекстовом режиме экран монитора компьютера обычно разбивается на 25 строк по 80 символов на строке.определить объем текстовой информации,занимающей весь экран монитора,в...
Chempionsyper
19.08.2020 05:26
Сколько текстовых файлов можно сохранить на флэш-накопителе объемом 4 гбайт, если каждый файл содержит 35 страниц, на каждой странице 40 строк, в каждой строке 45 символов?...
Rorschach001
19.08.2020 05:26
Перечислите сферы применения компьютеров....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
А получается он вот так:
procedure F(n:integer);
begin
Writeln('Вызов F(',n,')');
if n <= 5 then begin
F(n + 2);
writeln('Процедура вывела ',n);
F(n + 3)
end
end;
begin
f(1)
end.
Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)