В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lizismik15
lizismik15
16.08.2021 03:09 •  Информатика

Напишите программу для решения определить является ли данное число n чётным двухзначным числом

Ответ:
dfoddo
dfoddo
03.10.2020 20:47
Var
    n: integer;

begin
    readln(n);
    writeln((n mod 2 = 0) and (n div 10 > 0) and (n div 100 = 0));
end.
0,0(0 оценок)
Ответ:
amelisova06
amelisova06
03.10.2020 20:47
Var
     n,
     check_n,
     : integer;
     flag : boolean;
Begin
     write('Введите чило');
     readln(n);
   
{Проверяется, является ли n четным}
     if n mod 2 = 0
          then
               flag = true;
          else
               flag = false;
     
{Проверяется, является ли n двухзначным}
     if n div 10 <> 0
          then
               flag = true;
          else
               flag = false;

     if flag
          then
                writeln('Число ', n, ' является четным двухзначным');
          else
               writeln('Число ', n, ' не является четным двухзначным');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?