Войти
Регистрация
Спроси ai-bota
В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
Показать больше
Показать меньше
maя
23.07.2020 00:58 •
Информатика
Уровень c. введите массив с клавиатуры и найдите (за один проход) количество элементов, имеющих максимальное значение. пример: массив: 3 4 5 5 3 4 5 максимальное значение 5 количество элементов 3
Ответ:
WFCPDF
13.08.2020 17:48
Var
mas: array[1..7] of integer;
k, i, MAX:integer;
Begin
for i:=1 to 7 do
Begin
writeln('Введите число');
readln(mas[i]);
end;
MAX:=mas[1];
k:=1;
for i:=2 to 7 do
Begin
if mas[i] > MAX
then
Begin
MAX:=mas[i];
k:=1;
end
else
if MAX=mas[i]
then k:=k+1;
end;
writeln();
writeln('Максимальное значение = ', MAX);
writeln('Количество элементов = ', k);
readln();
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
диана2460
30.07.2021 05:52
Подумай Для чего используются команды Шрифт и Абзац при наборе текста? Сравни команды Шрифт и Абзац. Назови три основных отличия (...
Degradant81
20.04.2023 04:39
Для хранения растрового изображения размером 164х132 пикселей отвели 5 кб памяти. каково максимально возможное число цветов в палитре изображения...
fkffjfjfjfj
20.04.2023 04:39
Мешок деда мороза. в мешке у деда мороза лежат конфеты трех видов: шоколадные, ириски и леденцы. дед мороз знает, что если вынуть любые 98 конфет из мешка, то среди них обязательно...
Elv26
23.08.2021 02:55
Напишите программу для того, чтобы нарисовать светофор, а сверху надпись красный свет-дороги нет! в abc pascal. двадцать ....
evgehafly
23.08.2021 02:55
Напишите программу в паскале для решения : даны длины ребер прямоугольного параллелепипида. найти его объем и площадь поверхности. буду безумно !...
Витуся091
01.07.2021 18:57
Даны стороны прямоугольника a и b.составьте программу,которая вычисляет его площадь sи периметр р и выводит результат на экран !...
Данил2007Г
08.02.2020 09:19
Составьте программу дано натуральное n вычислить sin x +sin x^2+ x^n...
Fajeh
09.06.2020 23:40
Известны данные о мощности двигателя 30моделей. сколько машин мощностью выше 100лс. , нужно:...
LegendYT
09.06.2020 23:40
Склавиатуры вводится натуральное число, не превосходящее 1000. представить его в виде соответствующей словесной записи в паскале...
ммрк
09.06.2020 23:40
Составить программу, чтобы компьютер сгенерировал 10 случайных целых трехзначных чисел. длину определять с строковых функций. в паскале...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
mas: array[1..7] of integer;
k, i, MAX:integer;
Begin
for i:=1 to 7 do
Begin
writeln('Введите число');
readln(mas[i]);
end;
MAX:=mas[1];
k:=1;
for i:=2 to 7 do
Begin
if mas[i] > MAX
then
Begin
MAX:=mas[i];
k:=1;
end
else
if MAX=mas[i]
then k:=k+1;
end;
writeln();
writeln('Максимальное значение = ', MAX);
writeln('Количество элементов = ', k);
readln();
end.