В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
polinas6661
polinas6661
11.01.2020 09:00 •  Информатика

Написать программу на паскале : ) с процедуры задать матрицу a(n,m) датчиком случайных чисел. определить номера строки и столбца максимального элемента массива.

Ответ:
1236548
1236548
03.10.2020 03:07
Const n=4; m=5;
type ar=array[1..n,1..m] of integer;
procedure p1(var a:ar);
var i,j:integer;
begin
for i:=1 to n do begin
 for j:=1 to m do begin
   a[i,j]:=random(20)-10;
   write(a[i,j]:4);
  end;
  writeln;
end;
end;
var a:ar; i,j,max,im,jm:integer;
begin
Randomize;
p1(a);
max:=a[1,1]; im:=1; jm:=1;
for i:=1 to n do
 for j:=1 to m do
  if a[i,j]>max then
   begin max:=a[i,j]; im:=i; jm:=j; end;
writeln('max = a[',im,',',jm,'] = ',max);
end.

Пример:
   2  -1  -7   0   7
   3   7  -7  -7   3
  -7  -5  -3  -2   5
   9  -4  -4  -7  -7
max = a[4,1] = 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?