В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1660044
1660044
24.11.2020 06:15 •  Информатика

Дан текстовый файл. составьте программу, которая считывает текст из файла, вычисляет количество слов в каждой строке. вставьте в конце каждой строки количество слов и записать в новом файле.

Ответ:
Var  s          : string;  finish,k,i : longint;begin  assign(input,'input.txt'); reset(input);  assign(output,'output.txt'); rewrite(output);  finish:=0;  while(finish=0) do { если finish будет <> 0 то программа    перестанет читать текст}    begin      writeln('читать? если да, то 0 если нет, то 1');      readln(finish);      k:=0;      if finish=0        then begin               readln(s);               for i:=1 to length(s) do                 if s[i]=' '                   then inc(k);             end        else exit;      inc(k);      writeln(k);    end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?