В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
KendallK
KendallK
15.03.2020 22:33 •  Информатика

1) составьте программу, которая заполняет массив а[1..20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арефметическое элементов с четными значениями и нечетными индексами.

Ответ:
pharaohandtrasher
pharaohandtrasher
25.08.2020 07:17
Если надо найти ср. арифметическое одновременно и четных чисел и нечетных индексов:

var
a:array[1..20] of integer;
i, k, s: integer;
begin
for i:=1 to 20 do begin
a[i]:=random(1,10);
if (a[i] mod 2=0)or(i mod 2<>0) then begin
k:=k+1; s:=s+a[i]; end; end
writeln((s/k):17:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?