В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
matveyxhi
matveyxhi
17.10.2021 06:59 •  Информатика

Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений

Ответ:
Марина3611
Марина3611
03.10.2020 00:23
//Huh, if my Master wants.
var s,s1,s2:string;
begin;
write('String:');
readln(s);
write('Substring:');
readln(s1);
if length(s1)<>1 then exit;
while pos(s1,s)<>0 do
begin;
  s2:=s2+s[pos(s1,s)];
  delete(s,pos(s1,s),1);
  end;
write('Result:',length(s2));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?