В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aitbek99
aitbek99
13.07.2022 05:27 •  Информатика

Составьте программу для вычисления суммы ряда .s=2/3 *n + 2/3 * n^2 + 2/3 *n^n. с функцией или процедурой

Ответ:
7rus790
7rus790
02.10.2020 21:47
Program test;
function s(n,a:integer) : real;
var i,p:integer;
begin
  p:=1;
  if n>1 then begin
    for i:=1 to n do p:=p*a;
    s:=p;
  end;

end;
function sum(n:integer) : real;
var i:integer;
sum1:real;
begin
  for i:=1 to n do begin
    sum1:=sum1+(2/3)*s(i,n);
  end;
  sum:=sum1;
end;
var
  n:integer;
begin
  write('Введите количество чисел ');
  readln(n);
  writeln(sum(n));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?