В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
АлексейМв
АлексейМв
16.01.2023 06:05 •  Информатика

Составьте программу, которая заполняет массива а [1..8] соучайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и суумму элементов массива с нечетными значениями

Ответ:
nyutasova
nyutasova
29.07.2020 13:55
Program prog;
var a: array [1..8] of integer;
    k,s,i: integer;

begin
randomize;

for i:=1 to 8 do
begin
a[i]:=random(10)+1;
writeln('a[',i,'] = ', a[i]);
if a[i] mod 2 = 0 then
k:=k+1
else
s:=s+a[i];
end;
writeln;
writeln('Kolichestvo chetnyh k = ', k);
writeln('Summa nechetnyh S = ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?