В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Almira19681
Almira19681
21.01.2021 05:57 •  Информатика

Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. паскаль, соответственно.

Ответ:
LavaGuy111
LavaGuy111
29.07.2020 09:22
Var a,b,c,d:integer;
begin
for a:=1 to 10 do begin
  write('введите число=> ');
  readln(d);
  if (d mod 2=0) then c:=c+1 else d:=d+1;
  end;
writeln('чётных=> ',c,' нечётных=> ',d);
end.
0,0(0 оценок)
Ответ:
svetlana1968bup0c083
svetlana1968bup0c083
29.07.2020 09:22
Program znanija;
var s,nc,c,i:integer;
begin

for i:=1 to 10 do 
begin   
read(s);   
if odd(s) then inc(nc);   
if not odd(s) then inc(c); 
end;  

writeln('Чётных: ',c,' Не чётных: ', nc);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?