Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Gagarinaa
04.04.2020 23:35 •
Информатика
паскаль 8 класс! напишите программу, которая строит таблицу истинности для логической формулы (not a)or(not b)or c. подумайте сколько вложенных циклов вам понадобиться.
Ответ:
mrdrozdovoy228
02.10.2020 19:56
Uses Crt;
var
a,b,c:boolean;
begin
ClrScr;
for a:=False to True do
for b:=False to True do
for c:=False to True do
Writeln(a:6,b:6,c:6,(not a) or (not b) or c:6);
ReadKey
end.
Результат выполнения программы:
FALSE FALSE FALSE TRUE
FALSE FALSE TRUE TRUE
FALSE TRUE FALSE TRUE
FALSE TRUE TRUE TRUE
TRUE FALSE FALSE TRUE
TRUE FALSE TRUE TRUE
TRUE TRUE FALSE FALSE
TRUE TRUE TRUE TRUE
0,0
(0 оценок)
Популярные вопросы: Информатика
farangizuk
17.12.2021 07:33
Составить программу с цикла while, которая возведет числа от 1 до 10 во вторую степень....
resetmac
15.06.2020 17:41
Определите результат выполнения работы в phyton с переменной х=8 х=х+1...
8Мария11
09.02.2022 05:21
В ячейки A1 и B2 введены числа 24 и 12 соответственно. В ячейку C1 введено: A1/B1/Каков будет результат в ячейке С1...
arushikir
10.08.2020 20:39
Оценить, сколько дипломных работ вместится на лазерном диске ёмкостью 420 мбайт если одна работа составляет в средним 60 страниц по 45 строк в строке 30 символов...
Bexley
10.08.2020 20:39
Даны два числа. найти среднее арифметическое кубов этих чисел. что тут не так? ? program chisla; var a,b, sr: real; begin clrscr; writeln( vvedite chislo a= ); readln...
troft
10.08.2020 20:39
Выражение а^2*b^3/(a+b)*3 в паскале...
zholdashev
10.08.2020 20:39
Как сделать веб сайт? объясните все подробно пошагово, я все эти темы и сейчас не знаю как делать, в учебнике как- то все замудренно, а времени разбираться мало!...
Besmertnay123
22.12.2021 16:15
Расшифровать: текст зашифрован так: десять букв ( , , , , , , , , , ) разбиты на пары, и каждая из этих букв в тексте заменена второй из пары. все остальные символы...
koli17
10.09.2022 14:26
Решить уравнение. 19 целых 28 тридцать четвёртых - ( m + 2 целых 29 тридцать четвёртых )= 12 целых 15 тридцать четвёртых...
arrgitori
10.09.2022 14:26
Перечислите фокторы неживой природы,важные для существования животных....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a,b,c:boolean;
begin
ClrScr;
for a:=False to True do
for b:=False to True do
for c:=False to True do
Writeln(a:6,b:6,c:6,(not a) or (not b) or c:6);
ReadKey
end.
Результат выполнения программы:
FALSE FALSE FALSE TRUE
FALSE FALSE TRUE TRUE
FALSE TRUE FALSE TRUE
FALSE TRUE TRUE TRUE
TRUE FALSE FALSE TRUE
TRUE FALSE TRUE TRUE
TRUE TRUE FALSE FALSE
TRUE TRUE TRUE TRUE