В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
guka070806
guka070806
22.01.2023 20:52 •  Информатика

Написать программу: гречу, массой х г, рассыпают по пакетам: по а г в каждый. пакетов может быть неограниченное количество. сколько гречи будет в последнем заполненном пакете? , .

Ответ:
panoli2007
panoli2007
24.07.2020 10:56
// Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый. 
//Пакетов может быть неограниченное количество. Сколько гречи будет в
//последнем заполненном пакете?

var x,a  : longword;
begin
  writeln ('Введите общую массу гречи, в граммах');
  readln (x);
  writeln ('Введите массу насыпаемой в пакет гречи, в граммах');
  readln (a);
  writeln ('полных пакетов будет ',(x div a));
  if (x mod a)=0  then writeln ('В последнем насыпанном пакете будет ',a,' грамм гречи')
                  else writeln ('В последнем насыпанном пакете будет ',(x mod a),' грамм гречи');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?