В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Массив из 5 элементов заполняется целыми числами. составьте программу, которая вычисляет количество пар элементов, у которых один элемент - нечетный, а модуль второго меньше 5. парой элементов считаются два рядом стоящие элемента.

Ответ:
liya20042812
liya20042812
05.10.2020 17:47
Const
N = 5;

Var
A:array[1..N] of integer;
i,k:integer;

Begin
Write('Исходный массив: ');
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;
WriteLn;
k:=0;
For i:= 1 to N-1 do
    if ((A[i] mod 2 <> 0)and(abs(A[i+1])<5))
    or((A[i+1] mod 2 <> 0)and(abs(A[i])<5)) then k:=k+1;
WriteLn(k)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?