Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Раола
03.10.2021 00:49 •
Информатика
Написать программу в паскале "дано целое число n (> 0). найти наибольшее целое число к, квадрат которого не превосходит n : k^2 < = n. функцию извлечения квадратного корня не использовать. " (используя оператор while) ,
Ответ:
luska059
23.07.2020 08:28
Var N,k:integer;
begin
writeln('введите N');
readln(N); K:=n div 2;
while k*k>N do
k:=k-1;
writeln(k);
end.
{Возможны и другие варианты}
0,0
(0 оценок)
Популярные вопросы: Информатика
PabloDC
07.07.2021 02:13
Определите значение переменной а после выполнения алгоритма:а := 8;b := 3; b := a/2*b; a := 2*а + 3*b.2. Определите значение переменной b после выполнения алгоритма:а := 4;b...
BOMJangLOX
04.12.2021 16:27
Напишите программу в Pascal , кoторая выводит нa экран изображение ёлочки в виде звeздочек (*)...
анна2242
01.11.2022 09:24
50 ! решить по информатике: 80 бит= ? байт 5,5мбайт-? байт 7гбайта -? кбайт 3байт-? бит 1/2мбайт-? байт...
простахачууусписать
23.07.2022 19:13
Чему будет равно значение переменной К после выполнения операторов цикла K:=1; For i:=1 to 3 do K:=k+4 1)13 2)9 3)11...
лцстцлстлцс
05.01.2021 20:52
МНОГО ПАСКАЛЬ Напишите программу, которая выполняет сжатие массива – переставляет все нулевые элементы в конец массива. При этом все ненулевые элементы располагаются в начале...
алёнааепар
18.07.2022 08:19
Выберите элементы которые могут быть использованы в качестве авторских прав...
aleksBRO
11.02.2020 10:00
Нарисуйте трехмерную фигуру...
Natalye71
24.07.2020 13:44
Все на фото нужно как можно скорее!...
PaleMan2014
18.02.2020 02:53
Найти точки пересечения графиков функции y=-x2+3 и y=-2...
Fadasa
07.07.2022 08:43
Информатика python. Программа 1 Составь и запиши программу на языке Python: Если число кратно 7, возвести его в куб, иначе уменьшить данное число на 10. Программа 2 Составь...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
writeln('введите N');
readln(N); K:=n div 2;
while k*k>N do
k:=k-1;
writeln(k);
end.
{Возможны и другие варианты}